PAT--1136 A Delayed Palindrome(20 分)【大整数加法+reverse函数】

1136 A Delayed Palindrome(20 分)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

解题 思路:就是直接调用reverse函数,加法也是直接调用reverse函数,

#include<bits/stdc++.h>
using namespace std;
string add(string s)
{
	string a,t=s;
	int len=s.length();
	reverse(t.begin(),t.end());
	int c=0;
	for(int i=len-1;i>=0;i--)
	{
		int sum=(s[i]-'0'+t[i]-'0'+c)%10;
		c=(s[i]-'0'+t[i]-'0'+c)/10;
	        a+=char(sum+'0');
	}
	if(c) 
	{
		a+=char(c+'0');
	}
	reverse(a.begin(),a.end());
	return a;
}
int main(void)
{
	string s;
    cin>>s;
    int i;
    for(i=0;i<10;i++)
    {
    	string t=s;
    	reverse(t.begin(),t.end());
    	if(s==t) 
    	{
    		cout<<s<<" is a palindromic number.";
    		break;
		}
	        cout << s << " + " << t << " = " << add(s) << endl;//我栽在了输出格式,我没注意加号是有空格的,一直在找哪里格式错误,心好累
		s=add(s);	
	}
	if(i>=10) printf("Not found in 10 iterations.");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82226795