【PAT】A1136 A Delayed Palindrome (20point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1136 A Delayed Palindrome (20point(s))

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​ ⋯a1​​ a​0​​ with 0≤a​i​​ <10 for all i and a​k​​ >0. Then N is palindromic if and only if a​i​​ =a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

Code

#include <bits/stdc++.h>
using namespace std;
bool isPal(string s){
    for(int i=0;i<s.size()/2;i++){
        if(s[i]!=s[s.size()-i-1])
            return false;
    }
    return true;
}
string stringSum(string a,string b){
    int res[1010];
    string s;
    memset(res,-1,sizeof(res));
    for(int i=0;i<a.size();i++) res[i]=(a[i]-'0'+b[i]-'0');
    int i=0;
    while(res[i]!=-1){
        if(res[i]>=10){
            if(res[i+1]==-1)    res[i+1]=0;
            res[i+1]+=res[i]/10;
            res[i]%=10;
        }
        char t=res[i++]+'0';
        s+=t;
    }
    reverse(s.begin(),s.end());
    return s;
}
int main(){
    int n;
    string s,rs;
    cin>>s;
    if(isPal(s)==true)  cout<<s<<" is a palindromic number.\n";
    else{
        for(int i=0;i<10;i++){
            rs=s;
            reverse(rs.begin(),rs.end());
            if(isPal(s)==true){
                cout<<s<<" is a palindromic number.\n";
                return 0;
            }
            else    cout<<s<<" + "<<rs<<" = "<<stringSum(s,rs)<<"\n";
            s=stringSum(s,rs);
        }
        cout<<"Not found in 10 iterations.\n";
    }
    return 0;
}

Analysis

-给出一个初始的数,判断是否为回文数。若不是就将其与其每位逆转后的数相加,若仍然不是,则重复操作。

-若进行了10次相加操作,仍然得不到回文数,则输出"Not found in 10 iterations."。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103885764