1136 A Delayed Palindrome (20 分)(回文数,大数加法)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
const int N=1e5+5;
char a[N],b[N],c[N];
void add(char a[],char b[],char ans[]){
	int la=strlen(a+1);
	int lb=strlen(b+1);
	int tot=0;
	int tmp=0;//进位 
	int ta=la,tb=lb;
	while(ta>0&&tb>0){
		int cnt=(a[ta]-'0')+(b[tb]-'0')+tmp;
		c[++tot]=cnt%10+'0';
		tmp=cnt/10; 
		ta--;tb--;
	}
	while(ta>0){
		int cnt=(a[ta]-'0')+tmp;
		c[++tot]=cnt%10+'0';
		tmp=cnt/10; 
		ta--;
	}
	while(tb>0){
		int cnt=(b[tb]-'0')+tmp;
		c[++tot]=cnt%10+'0';
		tmp=cnt/10; 
		tb--;
	}
	if(tmp>0) c[++tot]=tmp+'0';
	int cnt=0;
	for(int i=tot;i>0;i--){
		ans[++cnt]=c[i];
	}
	ans[++cnt]='\0';
}
bool judge(char s[]){
	int l=1,r=strlen(s+1);
	while(l<r){
		if(s[l++]!=s[r--]) return false;
	}
	return true;
}
void reverse(char a[],char b[]){
	int len=strlen(a+1);
	for(int i=1;i<=len;i++) b[i]=a[len-i+1];
	b[len+1]='\0';
}
int main(){
    scanf("%s",a+1);
    if(judge(a)){
    	printf("%s is a palindromic number.\n",a+1);
    	return 0;
    }
    int step=1;
    bool flag=false;
    while(step<=10){
    	step++;
    	reverse(a,b);
    	printf("%s + %s = ",a+1,b+1);
    	add(a,b,a);
    	printf("%s\n",a+1);
    	if(judge(a)){
    		printf("%s is a palindromic number.\n",a+1);
    		flag=true;
    		break;
	}
    }
    if(!flag) printf("Not found in 10 iterations.\n");
    return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/103267772