PAT甲级--1136 A Delayed Palindrome (20 分)

1136 A Delayed Palindrome (20 分)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

 题目大意:判断回文数字,如果不是回文数字就经过一系列计算并输出计算过程。需要注意A和B的位数相同,即B的高位需要补零。数字的位数不超过1000,所以需要用字符串存储数字并另外写个函数进行逐位相加的操作。

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;

bool isPalindrome(string &s);
string Sum(const string &A,const string &B);

int main()
{
	int cnt=0;
	string A,B,sum;
	cin>>sum;
	if(isPalindrome(sum)){
	  printf("%s is a palindromic number.\n",sum.c_str());//如果是回文的话直接输出 
	  return 0;
	}
	while(1){
		A=sum;
		B.resize(A.size());
		reverse_copy(A.begin(),A.end(),B.begin());
		sum=Sum(A,B);
		cout<<A<<" + "<<B<<" = "<<sum<<endl;
		cnt++;
		if(isPalindrome(sum)){
			cout<<sum;
			printf(" is a palindromic number.\n");
			break;
		}
		if(cnt==10){
			printf("Not found in 10 iterations.\n");
			break;
		}
	}
	return 0;
 } 

string Sum(const string &A,const string &B)
{
	string sum;
	char c,next='0';
	for(int i=A.size()-1;i>=0;i--){
		c=A[i]+B[i]+next-'0'-'0';
		if(c<='9'){
			sum.insert(sum.begin(),c);
			next='0';
		}
		else{//当前位的数字相加大于10,则高位+1,当前位-10
			sum.insert(sum.begin(),c-'9'+'0'-1);
			next='1';
		}
	}
	if(next!='0') sum.insert(sum.begin(),next);
	return sum;
}

bool isPalindrome(string &s)
{
	if(s.size()==1) return true;
	if(s.size()==2){
		if(s[1]!=s[0]&&s[1]!=0) return false;
		else return true;
	}
	int k=s.size();
	if(s[0]!=s[k-1]&&s[k-1]!=0) return false;
	for(int i=1,j=k-2;i<j;i++,j--)
		if(s[i]!=s[j]) return false;
	return true;
}

猜你喜欢

转载自blog.csdn.net/weixin_44385565/article/details/88726041
今日推荐