Subsequence 尺取法

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3


思路来源:https://blog.csdn.net/helloiamclh/article/details/47685927

#include<iostream>
using namespace std;
#define min(a,b) a>b?b:a;
#define MAXN 100010
#define INF 0xfffffff
int a[MAXN];
int main()
{
	int n,N,S,l,r,len;
	long long sum  = 0;
	cin >>n;
	while(n--){
		cin>>N>>S;
		for(int i=0;i<N;i++){
			cin>>a[i];
		}
		l = r = 0;//初始化 
		sum = 0;
		len = INF;
		while(1){
			while(r<N && sum<S){ 
				sum+=a[r];
				r++;
			}//此时的sum是区间[l,r)上的和 
			if(sum<S){//如果说 sum<S但是r>=N了 结束循环 
				break;
			} 
			len = min(len,r-l);//更新长度 取较小的 
			sum -= a[l];//看看减去左边一个元素 还满不满足sum>=S 
			l++; //l右移一个 
		}
		if(len == INF){//如果说len没有变化 说明所有的数加起来<S 
			cout<<"0"<<endl; 
		}
		else{
			cout<<len<<endl;
		}
	}
	return 0;
}
最大子列和问题

给定N个整数的序列 a1,a2,,,,,, an 求 求做大子列和,如果子列和为负数,那么结果为0

#include<iostream>
using namespace std;
int a[100100];
int main()
{
	int maxsum,sum,N;
	maxsum = sum = 0;
	cin>>N;
	for(int i=0;i<N;i++){
		cin>>a[i];
	}//先读入数据 
	for(int i=0;i<N;i++){
		sum += a[i];
		if(sum > maxsum){
			maxsum = sum;
		}
		else if(sum <0 ){
			sum = 0;
		}
	}
	cout<<maxsum<<endl;
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/qq_39562286/article/details/80351188