1057 Stack(30 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/hy971216/article/details/82383225

1057 Stack(30 分)
Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
​5
​​ ). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian
where key is a positive integer no more than 10
​5
​​ .

Output Specification:
For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

分析:这道题除了要求实现栈的弹入和弹出操作,还要求查询栈内元素第k大(k是中位数),为了缩减时间复杂度,可以考虑分快思想,或者直接用树状数组

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>
#include<map>
#include<stack>
#include<algorithm>
using namespace std;
const int maxn = 100010;
const int sqrn = 316;
stack<int> st;
int block[sqrn];
int table[maxn];
void peekMedian(int k) {
    int sum = 0;
    int idx = 0;
    while(sum + block[idx] < k) {
        sum += block[idx++];
    }
    int num = idx * sqrn;
    while(sum + table[num] < k) {
        sum += table[num++];
    }
    printf("%d\n", num);
}
void Push(int x) {
    st.push(x);
    block[x / sqrn]++;
    table[x]++;
}
void Pop() {
    int x = st.top();
    st.pop();
    block[x / sqrn]--;
    table[x]--;
    printf("%d\n", x);
}
int main() {
    int x, query;
    memset(block, 0, sizeof(block));
    memset(table, 0, sizeof(table));
    char cmd[20];
    scanf("%d", &query);
    for(int i = 0; i < query; i++) {
        scanf("%s", cmd);
        if(strcmp(cmd, "Push") == 0) {
            scanf("%d", &x);
            Push(x);
        } else if(strcmp(cmd, "Pop") == 0) {
            if(st.empty() == true) {
                printf("Invalid\n");
            } else {
                Pop();
            }
        } else {
            if(st.empty() == true) {
                printf("Invalid\n");
            } else {
                int k = st.size();
                if(k % 2 == 1) {
                    k = (k + 1) / 2;
                } else {
                    k = k / 2;
                }
                peekMedian(k);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hy971216/article/details/82383225