1057 Stack (30 分)树状数组

1057 Stack (30 分)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​5​​). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10​5​​.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目大意:现请你实现一种特殊的堆栈,它多了一种操作叫“查中值”,即返回堆栈中所有元素的中值。对于N个元素,若N是偶数,则中值定义为第N/2个最小元;若N是奇数,则中值定义为第(N+1)/2个最小元。
分析:用排序查询的方法会超时~~用树状数组,即求第k = (s.size() + 1) / 2大的数。查询小于等于x的数的个数是否等于k的时候用二分法更快~

第一种:此题用排序查询的方法不能AC,但是简单能拿部分分数17分

第二种:AC的方法,使用树状数组来解决。因为此题即涉及排序,又涉及找到中间的数值(即用区间的和能反应出个数).关于树状数组的详细可以查看链接:

https://blog.csdn.net/qq_29762941/article/details/82784077

#include<stdio.h>
#include<string.h>
#include<stack>
#include<algorithm>
using namespace std;

const int maxn = 100001;
int c[maxn] = {0};

int lowbit(int n){
	return n & (-n);
} 

void update(int i,int val){
	while(i <= maxn){
		c[i] += val;
		i += lowbit(i);
	}
} 

int getsum(int i){
	int sum = 0;
	while(i > 0){
		sum += c[i];
		i -= lowbit(i);
	}
	return sum;
}

int Bsearch(int num){
	int l = 0,r = maxn-1,mid;
	while(l < r){
		mid = (l + r) / 2;
		int n = getsum(mid);
		//注意这里不能用n == num并返回mid,因为树状数组的c[i]是块状之和,部分sum[i]的值可能一样 
		//所以必须是一直向左移动获得最少的sum[i]下标 
		if(n >= num)
			r = mid;
		else
			l = mid + 1;
	}
	return r;
}


int main(){
	int n;
	scanf("%d",&n);
	char ch[11] = {0};
	stack<int> s;
	for(int i=0;i<n;i++)
	{
		scanf("%s",ch);
		if(ch[1] == 'e'){
			if(s.size() == 0)
				printf("Invalid\n");
			else{
				int num = s.size();
				if(num%2 == 0)
					num = num / 2;
				else
					num = (num+1) / 2;
				printf("%d\n",Bsearch(num));
			}
		}
		else if(ch[1] == 'o'){
			if(s.size() == 0)
				printf("Invalid\n");
			else{
				printf("%d\n",s.top());
				update(s.top(),-1);
				s.pop();
			}
		}
		else{
			int a;
			scanf("%d",&a);
			s.push(a);
			update(s.top(),1);
		}
	}
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82779154