暑假训练 The Necklace UVA - 10054 欧拉回路

题目描述:
My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace。。。
But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.
Please help me write a program to solve the problem.
Input
The input contains T test cases. The first line of the input contains the integer T.
The first line of each test case contains an integer N (5 ≤ N ≤ 1000) giving the number of beads
my sister was able to collect. Each of the next N lines contains two integers describing the colors of a
bead. Colors are represented by integers ranging from 1 to 50.
Output
For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence “some beads may be lost” on a line by itself. Otherwise, print N lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For 1 ≤ i ≤ N1, the second integer on line i must be the same as the first integer on line i + 1. Additionally, the second integer on line N must be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.
Print a blank line between two successive test cases.
Sample Input
2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4
Sample Output
Case #1
some beads may be lost
Case #2
2 1
1 3
3 4
4 2
2 2

代码:

#include<cstdio>
#include<string.h>

int in[55];
int graph[55][55];
int k;

void dfs(int a)
{
    for(int i = 1; i <= 50; i++)
    {
        if(graph[a][i] > 0)
        {
            graph[a][i]--;
            graph[i][a]--;
            dfs(i);
            printf("%d %d\n", i, a);   //一定要先递归后输出,不然珠子前后顺序接不上。。。
        }
    }
    return ;
}

bool reach(int next)              //判断欧拉图是否联通,其实所有数据都是联通的>_<
{
    in[next] = 0;
    for(int u = 1;u <= 50; u++)
        if(in[u] && (graph[next][u] || graph[u][next]))
        reach(u);
    for(int u = 1; u <= 50; u++)
        if(in[u])return false;
    return true;
}

bool test()
{
    for(int i = 1; i <= 50; i++)
    {
        if(in[i]%2 == 0)continue;
        else return false;
    }
    return reach(k);
}


int main()
{
    int t, n, a, b, p = 0, num;
    scanf("%d", &t);
    while(t--)
    {
        num = 0;
        memset(in, 0, sizeof in);
        memset(graph, 0, sizeof graph);
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &a, &b);
            in[a]++;
            in[b]++;
            graph[a][b]++;
            graph[b][a]++;
            k = a;
        }
        printf("Case #%d\n", ++p);
        if(!test())printf("some beads may be lost\n");
        else dfs(k);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wbl1970353515/article/details/82861229