HDU1003 Max Sum【基础DP 最大子段和】

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 302243    Accepted Submission(s): 71722


 

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

Author

Ignatius.L

问题链接:HDU1003 Max Sum

问题描述:给你一段整数序列(可能包含负数),求子段和最大的子段,输出最大和及其对应区间,如果有多个输出第一个。

解题思路:最大子段和,基础DP

AC的C++程序:

#include<iostream>
#include<algorithm>

using namespace std;

const int N=100010;
int a[N];

int main()
{
	int T,n;
	scanf("%d",&T);
	for(int t=1;t<=T;t++){
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		  scanf("%d",&a[i]);
		int l=1,l2=1,r=1,ans=-1001,sum=0;
		for(int i=1;i<=n;i++){
			sum+=a[i];
			if(sum>ans){
				ans=sum;
				l=l2;
				r=i;
			}
			if(sum<0){
				sum=0;
				l2=i+1;
			}
		}
		printf("Case %d:\n%d %d %d\n",t,ans,l,r);
		if(t!=T)
		  printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83791203