hdu1426

Sudoku Killer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6905    Accepted Submission(s): 2145


Problem Description
自从2006年3月10日至11日的首届数独世界锦标赛以后,数独这项游戏越来越受到人们的喜爱和重视。
据说,在2008北京奥运会上,会将数独列为一个单独的项目进行比赛,冠军将有可能获得的一份巨大的奖品———HDU免费七日游外加lcy亲笔签名以及同hdu acm team合影留念的机会。
所以全球人民前仆后继,为了奖品日夜训练茶饭不思。当然也包括初学者linle,不过他太笨了又没有多少耐性,只能做做最最基本的数独题,不过他还是想得到那些奖品,你能帮帮他吗?你只要把答案告诉他就可以,不用教他是怎么做的。

数独游戏的规则是这样的:在一个9x9的方格中,你需要把数字1-9填写到空格当中,并且使方格的每一行和每一列中都包含1-9这九个数字。同时还要保证,空格中用粗线划分成9个3x3的方格也同时包含1-9这九个数字。比如有这样一个题,大家可以仔细观察一下,在这里面每行、每列,以及每个3x3的方格都包含1-9这九个数字。

例题:


答案:

 

Input
本题包含多组测试,每组之间由一个空行隔开。每组测试会给你一个 9*9 的矩阵,同一行相邻的两个元素用一个空格分开。其中1-9代表该位置的已经填好的数,问号(?)表示需要你填的数。
 

Output
对于每组测试,请输出它的解,同一行相邻的两个数用一个空格分开。两组解之间要一个空行。
对于每组测试数据保证它有且只有一个解。
 

Sample Input
 
  
7 1 2 ? 6 ? 3 5 8 ? 6 5 2 ? 7 1 ? 4 ? ? 8 5 1 3 6 7 2 9 2 4 ? 5 6 ? 3 7 5 ? 6 ? ? ? 2 4 1 1 ? 3 7 2 ? 9 ? 5 ? ? 1 9 7 5 4 8 6 6 ? 7 8 3 ? 5 1 9 8 5 9 ? 4 ? ? 2 3
 

Sample Output
 
  
7 1 2 4 6 9 3 5 8 3 6 5 2 8 7 1 9 4 4 9 8 5 1 3 6 7 2 9 2 4 1 5 6 8 3 7 5 7 6 3 9 8 2 4 1 1 8 3 7 2 4 9 6 5 2 3 1 9 7 5 4 8 6 6 4 7 8 3 2 5 1 9 8 5 9 6 4 1 7 2 3



一道数独killerQAQ差点被数独给kill了QAQ弱渣还有许多需要学习

重要的事说三遍!!!!回溯里别定义全局变量,回溯里别定义全局变量回溯里别定义全局变量

好了数独之所以难,就是因为存在的可能太多,但是我们有dfs(大法师)呀!

思路:枚举每个未知的格子,再把每个数塞进去  大暴力的思路,但是注意找到答案立刻退出不要进行无谓的dfs

package 数独again;
import java.util.Scanner;
public class Main 
{
	public static void main(String args[])
	{
		Scanner s=new Scanner(System.in);
		boolean[][] vx=new boolean[10][10];
		boolean[][] vy=new boolean[10][10];
		int[][] a=new int[10][10];
		int[] dx=new int[100];
		int[] dy=new int[100];
		int kkkk=0;
		while (s.hasNext())
		{
		kkkk+=1;
		int tot=0;
		for (int i=1;i<=9;i++)
			for (int j=1;j<=9;j++)
			{
				vx[i][j]=true;
				vy[i][j]=true;
			}
		for (int i=1;i<=9;i++)
		{
			for (int j=1;j<=9;j++)
			{
				String p=s.next();
				char ch=p.charAt(0);
				if (ch=='?') 
					{
						ch='0';
						dx[tot]=i;dy[tot]=j;
						tot+=1;
					}
				a[i][j]=ch-'0';
				if (a[i][j]!=0)
				{
					vx[i][a[i][j]]=false;
					vy[j][a[i][j]]=false;
				}
			}
		}
		slove kk=new slove(vx,vy,a,tot,dx,dy);
		boolean wa;
		if (kkkk==1)
		wa=kk.dfs(0);
		else
		{
			System.out.println();
			wa=kk.dfs(0);
		}
	}
	}
}

class slove
{
	boolean[][] vx=new boolean[10][10];
	boolean[][] vy=new boolean[10][10];
	int[][] a=new int[10][10];
	int[] dx=new int[100];
	int[] dy=new int[100];
	int tot=0;
	boolean flag,flag2;
	public slove(boolean[][] vx,boolean[][] vy,int[][] a,int tot,int[] dx,int[] dy)
	{
		this.vx=vx;
		this.vy=vy;
		this.tot=tot;
		this.a=a;
		this.dx=dx;
		this.dy=dy;
	}
	boolean dfs(int sum)
	{
		if (sum==tot)
		{
			for (int i=1;i<=9;i++)
			{
				for (int j=1;j<=9;j++) 
					if (j!=9) System.out.print(a[i][j]+" ");
					else System.out.println(a[i][j]);
			}
			return true;
		}
		if (sum<tot)
		{
			int tx=dx[sum];int ty=dy[sum];
			for (int i=1;i<=9;i++)
			{
				flag=true;
				int x=(dx[sum]-1)/3*3+1;
				int y=(dy[sum]-1)/3*3+1;
				for (int o=x;o<=x+2;o++)
					for (int p=y;p<=y+2;p++)
						if (a[o][p]==i) flag=false;
				if ((vx[tx][i])&&(vy[ty][i])&&(flag))
				{
					a[tx][ty]=i;
					vx[tx][i]=false;
					vy[ty][i]=false;
					if (dfs(sum+1)) return true;
					a[tx][ty]=0;
					vx[tx][i]=true;
					vy[ty][i]=true;
				}
			}
		}
		return false;
	}
}




猜你喜欢

转载自blog.csdn.net/ruozhalqy/article/details/53057267