hdu1042N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 92483    Accepted Submission(s): 27501

http://acm.hdu.edu.cn/showproblem.php?pid=1042
 

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

 

Input

One N in one line, process to the end of file.

 

Output

For each N, output N! in one line.

 

Sample Input

1

2

3

 

Sample Output

1

2

6

代码:

import java.util.*;
import java.math.*;

public class jiecheng {
	public static void main(String[] args) {
		BigInteger sum;
		int n;
		Scanner cin=new Scanner(System.in);
		while(cin.hasNext()) {
			n=cin.nextInt();
			BigInteger a=BigInteger.valueOf(1);
			sum=a;
			for(int i=1;i<=n;i++) {
				BigInteger b=BigInteger.valueOf(i);
				sum=sum.multiply(b);
			}
			System.out.println(sum);
		}
		cin.close();
	}
}

猜你喜欢

转载自blog.csdn.net/sunny_hun/article/details/81771632