S - N! HDU - 1042(大数运算)

S - N!

HDU - 1042

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

1
2
6
#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=111;
const int mmax=111111;
const int MOD = 1e5+ 7;
int num[mmax];   //用数组保存每一位上得到的结果
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        int mod=0;   //保留进位
        int k=1;
        num[0]=1;
        for(int i=n;i>=1;i--){
            for(int j=0;j<k;j++){
             mod=num[j]*i+mod;
              num[j]=mod%10;
              mod=mod/10;
            }
            while(mod){  //处理最高位计算完后的进位
                num[k++]=mod%10;
              mod/=10;
            }
        }
        for(int i=k-1;i>=0;i--)
           printf("%d",num[i]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/clz16251102113/article/details/81217386