hdu 1042 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 90103    Accepted Submission(s): 26664

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file. 

Output

For each N, output N! in one line.


Sample Input

1

2

扫描二维码关注公众号,回复: 136917 查看本文章

3


Sample Output

1

2

6

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    int maxn=10005;
    void solve () {
        Scanner cin = new Scanner(System.in);
        int n;
        while(cin.hasNext()) {
            n=cin.nextInt();
            BigInteger ans=BigInteger.valueOf(1);
            for(int i=2;i<=n;i++) {
                ans=ans.multiply(BigInteger.valueOf(i));
            }
            System.out.println(ans);
        }
    }
    public static void main (String[] args) {
        Main work = new Main();
        work.solve ();
    }
}

猜你喜欢

转载自blog.csdn.net/qq_36914923/article/details/80180842