hdu 1014 +hdu 1019 (求最小公倍数或者排序)

题目:
Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input
3 5 15 20 63923 99999

Sample Output
3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
***理解:***就是给定两个数step, mod然后利用给定的公式求随机数,保证从0到mod减1范围内都均匀出现。
两种方法1, 求最大公约数,不是1 就good,2. 直接计算出所有的seed 然后排序,看是否和0-mod-1相等。
1.

//
//  main.cpp
//  hud1014
//
//  Created by zhan_even on 2018/10/20.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
using namespace std;

int gcd(int step, int mod){
    int z,i,gcdnum;
    gcdnum = 0;
    if(step<mod)
        z = step;
    else z = mod;
    for(i=z; i>0 ;i--){
        if(step%i==0 && mod%i==0){
            gcdnum = i;
            break;
        }
    }
    return gcdnum;
}
int main(int argc, const char * argv[]) {
    int step, mod;
    while (cin>>step>>mod) {
        printf("%10d%10d", step,mod);
        if (gcd(step, mod)==1)
            cout<<"    Good Choice"<<endl<<endl;
        else
            cout<<"    Bad Choice"<<endl<<endl;

        
    }
    return 0;
}

`
2.

//
//  main.cpp
//  hdu1013
//
//  Created by zhan_even on 2018/10/19.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
#include <algorithm>
using namespace std;

int main(int argc, const char * argv[]) {
    int step, mod, i;
    int s[100001];
    while (cin>>step>>mod) {
        s[0] = 0;
        for (i = 1; i<mod; i++)
            s[i] = (s[i-1] + step)%mod;
        sort(s, s+mod);
        for(i=0;i<mod;i++)
            if(s[i]!=i)
                break;
        printf("%10d%10d",step,mod);
        if(i==mod)
            cout<<"    Good Choice"<<endl<<endl;
        else
            cout<<"    Bad Choice"<<endl<<endl;
    }
    return 0;
}

`
hdu 1019

//
//  main.cpp
//  hdu1019
//
//  Created by zhan_even on 2018/10/20.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
using namespace std;


long long gcd(long long a, long long b){
    long long z,i,gcdnum;
    gcdnum = 0;
    if(a<b)
        z = a;
    else z = b;
    for(i=z; i>0 ;i--){
        if(a%i==0 && b%i==0){
            gcdnum = i;
            break;
        }
    }
    return gcdnum;
}


int main(int argc, const char * argv[]) {
    int pronum;
    cin >> pronum;
    while (pronum--) {
        int numnum;
        cin >> numnum;
        long long num[10000];
        int i;
        for(i = 0;  i<numnum; i++){
            if (i == 0) {
                cin >> num[i];
            }
            else{
                cin >> num[i];
                num[i]=num[i-1]*num[i]/gcd(num[i-1],num[i]);
            }
        }
        cout << num[numnum-1] <<endl;
            
        
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41568105/article/details/83214527
今日推荐