hdu 1108 最小公倍数【简单数论】

最小公倍数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66154    Accepted Submission(s): 36375


Problem Description
给定两个正整数,计算这两个数的最小公倍数。
 

Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
 

Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
 

Sample Input
 
  
10 14
 

Sample Output
 
  
70

简单数论,lcm(a,b)=a*b/gcd(a,b)=a/gcd(a,b)*b.

import java.util.Scanner;

public class Main {
    public static int gcd(int a,int b)
    {
        int r;
        while(b != 0)
        {
            r = a%b;
            a = b;
            b = r;
        }
        return a;
    }
    public static int lcm(int a,int b)
    {
        return a/gcd(a,b)*b;
    }
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext())
        {
            int a = sc.nextInt();
            int b = sc.nextInt();
            System.out.println(lcm(a,b));
        }
        
    }

}

猜你喜欢

转载自blog.csdn.net/qq_34229351/article/details/80301539