最小公倍数 HDU - 1108

给定两个正整数,计算这两个数的最小公倍数。

Input

输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.

Output

对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。 

Sample Input

10 14

Sample Output

70

AC代码(模板题)

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int gcd(int a, int b)
{
    return !b?a:gcd(b, a%b);
}
int lcm(int a, int b)
{
    return a*b/gcd(a,b);
}
int main()
{
    std::ios::sync_with_stdio(false);
    int a, b;
    while(cin>>a>>b)
    printf("%d\n",lcm(a, b));
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41524782/article/details/81782209