HDU - 1019 最小公倍数

HDU - 1019 最小公倍数

只是学习一下
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296

代码块

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int yue(int a,int b)
{
    int t,c;
    if(a<b) {t=a;a=b;b=t;}
    if(a%b==0) return b;
    else
    {
        c=a%b;
        a=b;b=c;
        return yue(a,b);
    }
}
int main()
{
     int t,n,aa,a,i;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%d%d",&n,&aa);
         for(i=1;i<n;i++)
         {
             scanf("%d",&a);
             aa=aa/yue(aa,a)*a;
         }
         printf("%d\n",aa);
     }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sun1311523821/article/details/81982306