POJ-2566-Bound Found (尺取法)

版权声明:欢迎评论与转载,转载时请注明出处! https://blog.csdn.net/wjl_zyl_1314/article/details/84035613

原题链接
http://poj.org/problem?id=2566
Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15
题意:
有一个长度为n的数列,要求从中找出连续的子序列满足子序列和的绝对值最接近t(输入值),输出最接近的值和区间左右端点。
题解:
找寻左右区间,尺取法很明显,唯独就是要注意数据范围。
尺取具体思想也就是区间枚举,更多细节看代码。
附上AC代码:

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
const int inf=1<<30;
const int maxn=1e5+1000;
int n,k,sum;
pair<int,int> g[maxn];
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>k,n+k)
    {
        sum=0;
        g[0]=make_pair(0,0);
        for(int i=1;i<=n;i++)
        {
            int val;
            cin>>val;
            sum+=val;//类似于前缀和
            g[i]=make_pair(sum,i);//建立对应关系
        }
        sort(g,g+n+1);//排序方便计算
        while(k--)
        {
            int t;
            cin>>t;
            int pre=0,last=1,val=inf,ans,ansl=1,ansr=1;
            while(last<=n&&val)//遍历尺取&&当val==0时,即找到与t相等的区间
            {
                int num=g[last].first-g[pre].first;//区间内的和的绝对值
                if(abs(num-t)<val)//如果更加接近t
                {
                    val=abs(num-t);
                    ans=num;
                    ansl=g[pre].second;
                    ansr=g[last].second;
                }
                if(num<t)//小了
                    last++;
                if(num>t)//大了
                    pre++;
                if(pre==last)//区间左右端点相同
                    last++;
            }
            if(ansl>ansr)//因为排序过所以顺序不定
                swap(ansl,ansr);
            cout<<ans<<" "<<ansl+1<<" "<<ansr<<endl;
        }
    }
    return 0;
}

欢迎评论!

猜你喜欢

转载自blog.csdn.net/wjl_zyl_1314/article/details/84035613