poj 2566 Bound Found

Bound Found

Time Limit: 5000MS Memory Limit: 65536K

Total Submissions: 7891 Accepted: 2572 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 
You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1 -10 -5 0 5 10 3 10 2 -9 8 -7 6 -5 4 -3 2 -1 0 5 11 15 2 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 15 100 0 0 

Sample Output

5 4 4 5 2 8 9 1 1 15 1 15 15 1 15

题意:求一个子区间权值和的绝对值与t相差最少。

题解:尺取法。尺取法维护的数列必须具有单调性,而此题中数值有正有负,不满足单调性。所以间接利用前缀和进行尺取法。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=100005,inf=0x7fffffff;
struct node
{
  int id,sum;
  node(){}
  node(int a,int b)
  {id=a;sum=b;}
  bool operator <(const node&n) const
  {return sum<n.sum;}
}w[maxn];
int n;
void solve(int t);
int main()
{
  int i,k,t,x;
  while(~scanf("%d%d",&n,&k))
  {
    if(!n&&!k) break;
    w[0]=node(0,0);
    for(i=1;i<=n;i++) 
    {
     scanf("%d",&x);
     w[i]=node(i,w[i-1].sum+x);
    }
    sort(w,w+n+1);
    while(k--)
    {
     scanf("%d",&t);
     solve(t);
    }
  }
  return 0;
}
void solve(int t)
{
  int ansl,ansr,i,j,sum,mmin=inf,ans;
  for(j=1,i=0;j<=n&&i<=n;)
  {
    sum=w[j].sum-w[i].sum;
    if(abs(sum-t)<mmin)
     {
       ans=sum;
       mmin=abs(sum-t);
       ansl=w[i].id;
       ansr=w[j].id;
     }
    if(sum>t) i++;
    else if(sum<t) j++;
    else break;
    if(i==j) j++;
  }
  if(ansl>ansr) swap(ansl,ansr);
  printf("%d %d %d\n",ans,ansl+1,ansr);
}

猜你喜欢

转载自www.cnblogs.com/VividBinGo/p/11369983.html