Bound Found (POJ-2566) (尺取)

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

题意:给出一个整数列,求一段子序列之和最接近所给出的t。输出该段子序列之和及左右端点。

思路:预处理出前i个数的前缀和,和编号i一起放入pair中,然而根据前缀和大小进行排序。由于abs(sum[i]-sum[j])=abs(sum[j]-sum[i]),可以忽视数列前缀和的前后关系。此时,sum[r]-sum[l]有单调性。因此我们可以先比较当前sum[r]-sum[l]与t的差,并更新答案。如果当前sum[r]-sum[l]<t,说明和还可以更大,r++。同理,如果sum[r]-sum[l]>t,说明和还可以更小,l++。如果sum[r]-sum[l]=t,必定是最小答案。

AC代码:

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int maxx=100010;
const int inf=0x3f3f3f3f;
pair<int,int>sum[maxx];
int n,k,t;
int main()
{
    while(~scanf("%d%d",&n,&k),n,k)
    {
        sum[0]=make_pair(0,0);
        int tmp=0;
        for(int i=1; i<=n; i++)
        {
            int x;
            scanf("%d",&x);
            tmp+=x;
            sum[i]=make_pair(tmp,i);
        }
        sort(sum,sum+n+1);
        for(int i=1; i<=k; i++)
        {
            scanf("%d",&t);
            int l=0,r=1,minn=inf,ans,ansl,ansr;
            while (r<=n && minn)
            {
                int cnt=sum[r].first-sum[l].first;
                if (abs(cnt-t)<=minn)
                {
                    minn=abs(cnt-t);
                    ans=cnt;
                    ansl=sum[l].second;
                    ansr=sum[r].second;
                }
                if (cnt<t)
                    r++;
                if (cnt>t)
                    l++;
                if (l==r)
                    r++;
            }
            if(ansl>ansr)
                swap(ansl,ansr);
            printf("%d %d %d\n",ans,ansl+1,ansr);
        }
    }
    return 0;
}
发布了204 篇原创文章 · 获赞 16 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43846139/article/details/103493682