PAT (Advanced Level) Practice 1061 Dating (20 分)(C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85836454

1061 Dating (20 分)

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:

THU 14:04

//和乙级题1014 福尔摩斯的约会 (20 分)一样
//https://blog.csdn.net/m0_37454852/article/details/85396340
#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	char str1[80], str2[80], str3[80], str4[80];
	scanf("%s", str1);//输入字符串
	scanf("%s", str2);
	scanf("%s", str3);
	scanf("%s", str4);
	int len1 = strlen(str1);//各字符串长度
	int len2 = strlen(str2);
	int len3 = strlen(str3);
	int len4 = strlen(str4);
	char DAY[7][5] = { "MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN" };//日期
	int flag = 0;//前两个串匹配时输出日期或是小时
	int len = len1 < len2 ? len1 : len2;//前两个串长的较小值
	for (int i = 0; i < len; i++)
	{
		if (str1[i] >= 'A' && str1[i] <= 'G' && str1[i] == str2[i] && !flag)
		{
			printf("%s", DAY[(str1[i] - 'A')]);//输出日期
			flag = 1;
		}
		else if (flag && str1[i] == str2[i])
		{
			if (str1[i] >= '0' && str1[i] <= '9')
			{
				printf(" 0%d:", str1[i]-'0');//小时不足两位则补零
				break;
			}
			else if (str1[i] >= 'A' && str1[i] <= 'N')
			{
				printf(" %d:", str1[i]-'A'+10);
				break;
			}
		}
	}
	len = len3 < len4 ? len3 : len4;//后两个串长的较小值
	for (int i = 0; i < len; i++)
	{
		if (str3[i] == str4[i] 
			&& ( (str3[i]>='a' && str3[i] <= 'z') || (str3[i] >= 'A' && str3[i] <= 'Z') ))
		{
			if(i<10) printf("0%d", i);//分钟不足两位则补零
			else printf("%d", i);
			break;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85836454