PAT (Advanced Level) Practice 1065 A+B and C (64bit) (20 分)(C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85635534

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2
​63
​​ ,2
​63
​​ ], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:

Case #1: false
Case #2: true
Case #3: false

//这个题在乙级题中已经做过了,当时的一种方案直接拿过来把int改成long long int 直接就通过了
//两个正数相加溢出为正数,两个负数相加溢出为正数
//正负相加不会溢出

#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	int T = 0;
	long long int A, B, C;
	scanf("%d", &T);
	for (int i = 1; i <= T; i++)
	{
		scanf("%lld %lld %lld", &A, &B, &C);
		long long int D = A + B;
		if (D <= 0 && A>0 && B > 0) printf("Case #%d: true\n", i);//判断越界时的状态
		else if (D >= 0 && A < 0 && B < 0) printf("Case #%d: false\n", i);
		else if (D > C) printf("Case #%d: true\n", i);//否则正常比较输出即可
		else printf("Case #%d: false\n", i);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85635534