PAT甲级--1065 A+B and C (64bit)(20 分)【溢出(正正负,负负正)】

1065 A+B and C (64bit)(20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

解题思路:这题很简单,就是那些特别判断一下溢出的就好了。

#include<iostream>
#include<cstdio>
using namespace std;
int main(void)
{
	int t,k=0;
	scanf("%d",&t);
	while(t--)
	{
		long long a,b,c,sum=0;
		int flag=0;
		cin>>a>>b>>c;
		sum=a+b;
		if(sum<0)
		{
			if(a>0&&b>0) flag=1;
			else if(sum>c) flag=1;
		}
		else
		{
			if(a<0&&b<0) flag=0;
			else if(sum>c) flag=1;
		}

		printf("Case #%d: %s\n",++k,flag?"true":"false");
	}
	return 0;
}

 代码更短一点:

#include<iostream>
#include<cstdio>
using namespace std;
int main(void)
{
	int t,k=0;
	scanf("%d",&t);
	while(t--)
	{
		long long a,b,c,sum=0;
		int flag=0;
		cin>>a>>b>>c;
		sum=a+b;
		if(a>0&&b>0&&sum<0) flag=1;
		else if(a<0&&b<0&&sum>=0) flag=0;
		else if(sum>c) flag=1;
		printf("Case #%d: %s\n",++k,flag?"true":"false");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82081592