PAT-A 1065. A+B and C (64bit) (20)(20 分)

https://pintia.cn/problem-sets/994805342720868352/problems/994805406352654336

1065 A+B and C (64bit) (20)(20 分)

Given three integers A, B and C in [-2^63^, 2^63^], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B&gtC, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
#include <iostream>
#include<cstdio>
using namespace std;
typedef long long ll; 

int main(int argc, char** argv) {
	ll a,b,c;
	int t;
	cin>>t;
	for(int i=0;i<t;i++){
		scanf("%lld%lld%lld",&a,&b,&c);
		getchar();
		ll sum=a+b;
		bool flag;
		if(a>0&&b>0&&sum<0){ //正溢出,满足a+b>c 
			flag=true;
		}
		else if(a<0&&b<0&&sum>=0){//负溢出,不满足 
			flag=false;
		}
		else if(sum>c){//a,b任意,无溢出,满足 
			flag=true;
		} 
		else{// 无溢出,不满足 
			flag=false;
		} 
		if(flag){
			printf("Case #%d: true\n",i+1);
		} else{
			printf("Case #%d: false\n",i+1);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81158879