1065 A+B and C (64bit)(20 分)

1065 A+B and C (64bit)(20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

 int  4 个字节

double 8 个字节 double 可以表示 1.0 * 10^308 的范围,但是缺点是损失精度。

long long 8个字节 

code

#pragma warning(disable:4996)
#include <iostream>
#include <math.h>
using namespace std;
int main(){
	int n;
	cin >> n;
	long double a, b, c;
	for(int i=1;i<=n;++i) {
		cin >> a >> b >> c;
		cout << "Case #"<<i<<": ";
		long double sum = c - b;
		if (a > sum) {
			cout << "true" << endl;
		}
		else {
			cout << "false" << endl;
		}
	}
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82217915