【PAT 甲级】1065 A+B and C (64bit) (20)(20 分)

题目链接

Given three integers A, B and C in [-2^63^, 2^63^], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B&gtC, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false

Case #2: true

Case #3: false

思路:注意溢出。 long long 的范围是[-2^63,2^63-1) 
正数之和为负数或者负数之和为正数就算是溢出 
A+B必须放在long long 中存下才能进行比较,不能直接在if中比较。 

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N = 2e3+10;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;
const int T=3;

int main() {
    int T;
    int ncase=1;
    scanf("%d",&T);
    while(T--) {
        ll a,b,c;
        scanf("%lld%lld%lld",&a,&b,&c);
        ll ans=a+b;
        printf("Case #%d: ",ncase++);
        if(a>0&&b>0&&ans<0)
            printf("true\n");
        else if(a<0&&b<0&&ans>=0)
            printf("false\n");
        else if(ans>c)
            printf("true\n");
        else
            printf("false\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/80904950