【笨方法学PAT】1065 A+B and C (64bit) (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/83311475

一、题目

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

二、题目大意

判断a+b是否大于c。

三、考点

基本数据类型的性质

四、注意

1、使用大数加法的话,很麻烦;

2、利用数据类型的性质,内存溢出,导致数组符号改变。

五、代码

#include<iostream>
using namespace std;
int main() {
	//read
	int n;
	cin >> n;
	for (int i = 1; i <= n; ++i) {
		long long int a, b, c,d;
		cin >> a >> b >> c ;
		d = a + b;

		//solve
		if (a > 0 && b > 0 && d <= 0)
			printf("Case #%d: true\n", i);
		else if (a < 0 && b < 0 && d >= 0)
			printf("Case #%d: false\n", i);
		else {
			if (d > c) 
				printf("Case #%d: true\n", i);
			else
				printf("Case #%d: false\n", i);
		}
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/83311475