PAT (Advanced Level) Practice 1058 A+B in Hogwarts (20 分) (C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85789975

1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10
​7
​​ ], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27
Sample Output:

14.1.28


//和之前的一个B类题比较类似

#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	long long int Galleon1, Sickle1, Knut1;//中间结果用int的话可能溢出,索性全都用longlong了
	long long int Galleon2, Sickle2, Knut2;//当然,中间计算的时候加个强转也行
	scanf("%lld.%lld.%lld", &Galleon1, &Sickle1, &Knut1);
	scanf("%lld.%lld.%lld", &Galleon2, &Sickle2, &Knut2);
	long long int sum = Galleon1 * 29 * 17 + Sickle1 * 29 + Knut1;
	sum += Galleon2 * 29 * 17 + Sickle2 * 29 + Knut2;
	printf("%lld.%lld.%lld", sum / 493, (sum / 29) % 17, sum % 29);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85789975