PAT(甲级)1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

简析:和乙级的一道题类似,主要是把减改成了加,然后有个测试点会错因为int不够,得用long long。

#include<iostream>
using namespace std;
int main()
{
    long long n[2] = {0};
    long long a, b, c;
    for (int t = 0; t < 2;t++)
    {
        scanf("%d.%d.%d", &a, &b, &c);
        n[t] = c + b * 29 + a * 17 * 29;
    }
    long long n1 = n[1] + n[0];
    a = n1 / (29 * 17);
    cout << a<<'.';
    n1 = n1 % (29 * 17);
    b = n1 / 29;
    cout << b << '.';
    c = n1 % 29;
    cout << c;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35601980/article/details/89302906