1058 A+B in Hogwarts (20分)

1058 A+B in Hogwarts (20分)

题目:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27 

### Sample Output:

14.1.28

题意:

17 Sickle = 1 Galleon ; 29 Knuts = 1 Sickle

例子:

3.2.1 + 10.16.27 = 13.18.28 = 14.1.28

题解:

#include <cstdio>
int main() {
    int ag,as,ak,bg,bs,bk,g,s,k;
    scanf("%d.%d.%d %d.%d.%d",&ag,&as,&ak,&bg,&bs,&bk);
    g = ag + bg;
    s = as + bs;
    k = ak + bk;
    if(k >= 29) s += (k / 29), k %= 29;
    if(s >= 17) g += (s / 17), s %= 17;
    printf("%d.%d.%d",g,s,k);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/F4lc0n/p/12235188.html