1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

答案如下:


#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<stack>
using namespace std;
struct A {
	int a[3] = { 0 };
}t[2];
int main() {
	A c;
	for (int i = 0; i < 2; i++) {
		for (int j = 0; j < 3; j++) {
			cin >> t[i].a[j];
			getchar();
			c.a[j] += t[i].a[j];
		}
	}
	for (int i = 2; i >= 0; i--) {
		if (i ==2 && c.a[i] >= 29) {
			c.a[1]++;
			c.a[2] -= 29;
		}
		else if (i == 1 && c.a[i] >= 17) {
			c.a[0]++;
			c.a[1] -= 17;
		}
	}
	cout << c.a[0] << "." << c.a[1] << "." << c.a[2] << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41937767/article/details/85393258