1058 A+B in Hogwarts (20分)【进制转换】

1058 A+B in Hogwarts (20分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28
#include<iostream>
using namespace std;

int main()
{
	int s1, g1, k1, s2, g2, k2;
	scanf("%d.%d.%d %d.%d.%d", &g1, &s1, &k1, &g2, &s2, &k2);
	int resS, resG, resK;
	int tmp;     //进位
	resK = (k1 + k2) % 29;
	tmp = (k1 + k2) / 29;
	resS = (s1 + s2 + tmp) % 17;
	tmp = (s1 + s2 + tmp) / 17;
	resG = g1 + g2 + tmp;
	cout << resG << "." << resS << "." << resK << endl;
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104634063