A1058 A+B in Hogwarts (20)

1058 A+B in Hogwarts (20)(20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 10^7^], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

思路:

        和前面做过的题目类似,就是多了一个A+B,

        思想就是把大数全部转换成小数,然后到输出的时候再把小数根据进制转换到大数上

#include <cstdio>
// 17 Sickles to a Galleon 
// 29 Knuts  to a Sickles
int main(){
	long long sick=0,gall=0,knuts=0;
	int a,b,c;
	long long sum;
	int i=2;
	while(i--){
		scanf("%d.%d.%d",&a,&b,&c);
		gall+=a;
		sick+=b;
		knuts+=c;	
	}
	sum=knuts+sick*29+gall*29*17;//转化为最小单位 
	printf("%d.%d.%d",sum/(29*17),sum%(17*29)/29,sum%29);
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_40959340/article/details/81590655