A1058. A+B in Hogwarts (20)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28   

题目大意:

利用霍格沃兹的货币系统,对两个数据进行相加,求出之后的值;

B1037类似。

思路:

用数组存储,利用取模和整取运算进行进位;

代码如下:

#include <cstdio>

int main()
{
	int a[3], b[3], c[3];
	scanf ("%d.%d.%d %d.%d.%d", &a[0], &a[1], &a[2], &b[0], &b[1], &b[2]);
	
	int carry = 0;
	c[2] = (a[2] + b[2]) % 29;
	carry = (a[2] + b[2]) / 29;			//获取进位; 
	c[1] = (a[1] + b[1] + carry) % 17;
	carry = (a[1] + b[1] + carry) / 17;		//carry值也要加入计算; 
	c[0] = a[0] + b[0] + carry;
	
	printf ("%d.%d.%d", c[0], c[1], c[2]);
 	return 0;
}

猜你喜欢

转载自blog.csdn.net/privilage/article/details/79953193