PAT甲级---1058 A+B in Hogwarts (20 分)

PAT甲级—1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10
7
], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

#include<iostream>
#include<cstring>

using namespace std;

int main(){
    
    
	int a1,b1,c1,a2,b2,c2,a,b,c;
	scanf("%d.%d.%d %d.%d.%d",&a1,&b1,&c1,&a2,&b2,&c2);
	c=c1+c2;
	b=b1+b2;
	a=a1+a2;
	if(c>=29){
    
    
		b=b+c/29;
		c=c%29;
	}
	if(b>=17){
    
    
		a=a+b/17;
		b=b%17;
	}
	
	printf("%d.%d.%d\n",a,b,c);
	
	return 0;
}

部分正确18分
参考答案

#include <iostream>
using namespace std;
int main() {
    
    
    int a1, b1, c1, a2, b2, c2, a, b, c;
    scanf("%d.%d.%d %d.%d.%d", &a1, &b1, &c1, &a2, &b2, &c2);
    c = c1 + c2;
    b = b1 + b2 + c / 29; c = c % 29;
    a = a1 + a2 + b / 17; b = b % 17;
    printf("%d.%d.%d\n", a, b, c);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44411458/article/details/123232673