【笨方法学PAT】1058 A+B in Hogwarts (20 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/83305364

一、题目

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

二、题目大意

给定两串数字,求加法;数字要按照规定进行进制转换。

三、考点

进制转换

四、注意

1、使用int可能会越界,使用long long int。

五、代码

#include<iostream>
using namespace std;
int main() {
	//read
	long long int a1, a2, a3, b1, b2, b3;
	scanf("%lld.%lld.%lld %lld.%lld.%lld", &a1, &a2, &a3, &b1, &b2, &b3);

	//change into Knuts
	long long int a = a1 * 17 * 29 + a2 * 29 + a3;
	long long int b = b1 * 17 * 29 + b2 * 29 + b3;

	//result
	long long int c = a + b,c1,c2,c3;
	c1 = c / 17 / 29;
	c2 = (c - c1 * 17 * 29) / 29;
	c3 = c - c1 * 17 * 29 - c2 * 29;
	printf("%lld.%lld.%lld", c1, c2, c3);

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/83305364