【PAT】A1058. A+B in Hogwarts (20)

Description:
If you are a fan of Harry Potter, you would know the world of magic has its own currency system — as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 10^7], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27


Sample Output:

14.1.28

//NKW 甲级真题1018
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
int main(){
	int g = 0, s = 0, k = 0, gg, ss, kk;
	for (int i = 2; i > 0; i--){
		scanf("%d.%d.%d", &gg, &ss, &kk);
		g += gg;
		s += ss;
		k += kk;
	}
	if (k >= 29){
		s += k / 29;
		k = k % 29;
	}
	if (s >= 17){
		g += s / 17;
		s = s % 17;
	}
	printf("%d.%d.%d\n", g, s, k);
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/80918928