PAT甲级 1058 A+B in Hogwarts (20 分)水题

1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

题目大意:17个Sickle对换一个Galleon,29个Knut对换一个Sickle。根据Galleon.Sickle.Knut的方式相加A和B

#include<iostream>
#include<algorithm>
using namespace std;

int main(){
	int a,b,c;//第一个输入 
	int d,e,f;//第二个输入 
	int g,h,i;//结果 
	scanf("%d.%d.%d %d.%d.%d",&a,&b,&c,&d,&e,&f);
	
	int flag = 0;
	i = c+f;
	if(i >= 29){
		i -= 29;
		flag = 1;
	}
			
	h = b+e+flag;
	flag = 0;
	if(h >= 17){
		h -= 17;
		flag = 1;
	}
	
	g = a+d+flag;
	printf("%d.%d.%d",g,h,i);
		
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82717917