1058 A+B in Hogwarts(20 分)(cj)

1058 A+B in Hogwarts(20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
using namespace std;
class number {
public:
	int a, b, d;
	number operator + (const number& x) {
		number c;
		c.a = a + x.a;
		c.b = b + x.b;
		c.d = d + x.d;
		c.b += (c.d / 29);
		c.d %= 29;
		c.a += (c.b / 17);
		c.b %= 17;
		return c;
	}
	void print() {
		cout << a << '.' << b << '.' << d << endl;
	}
};
int main(){
	number A, B;
	scanf("%d.%d.%d %d.%d.%d", &A.a, &A.b, &A.d,&B.a,&B.b,&B.d);
	number C;
	C = A + B;
	C.print();
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82049679