PTA甲级 1058 A+B in Hogwarts (20分)-水题

题目原文

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

代码

#include<iostream>
#include<cstdio>
using namespace std;
struct Money {
	int Galleon;
	int Sickle;
	int Knut;
};
int main(void) {
	struct Money P, A, D;
	int sym = 0;
	int flag = 0;
	scanf("%d.%d.%d %d.%d.%d", &P.Galleon, &P.Sickle, &P.Knut, &A.Galleon, &A.Sickle, &A.Knut);
	/*if (A.Galleon * 17 * 29 + A.Sickle * 29 + A.Knut < P.Galleon * 17 * 29 + P.Sickle * 29 + P.Knut) {
		D = A;
		A = P;
		P = D;
		sym = 1;
	}*/

	if (A.Knut + P.Knut >= 29) { 
		D.Knut = A.Knut + P.Knut - 29; 
		flag = 1;
	}
	else {
		D.Knut = A.Knut + P.Knut;
	}
	if (flag == 1) {
		A.Sickle++;
		flag = 0;
	}
	if (A.Sickle + P.Sickle >= 17) {
		D.Sickle = A.Sickle + P.Sickle-17; flag = 1;
	}
	else {
		D.Sickle = A.Sickle + P.Sickle;
	}
	if (flag == 1) {
		A.Galleon++;
		flag = 0;
	}
	D.Galleon = A.Galleon + P.Galleon;
	cout << D.Galleon << '.' << D.Sickle << '.' << D.Knut;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Huangpengyu123/article/details/107076323