PAT 甲级 1018 Public Bike Management

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/86561056

1018 Public Bike Management (30 point(s))

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

Experiential Summing-up

The hard point of this question lie in the method of selecting optimal path. Not only consider the least number of send but also consider the least number of take back. This question using adjective table is faster than using adjctive matrix. Futhermore, notice store the same short paths. That's all~

 (The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=510;
const int INF=0x3fffffff;
int Cmax,Spr,m,n,C[maxn],d[maxn];
bool vis[maxn];
vector<int> pre[maxn];
struct node
{
	int v,w;
	node(int a,int b):v(a),w(b){}
};
vector<node> adj[maxn];
void Dijkstra(int s)
{
	memset(vis,0,sizeof(vis));
	fill(d,d+maxn,INF);
	d[s]=0;
	for(int i=0;i<=n;++i)
	{
		int min=INF,u=-1;
		for(int j=0;j<=n;++j)
		{
			if(d[j]<min&&vis[j]==false)
			{
				u=j;
				min=d[j];
			}
		}
		if(u==-1)
			return ;
		vis[u]=true;
		for(int j=0;j<adj[u].size();++j)
		{
			int v=adj[u][j].v;
			int w=adj[u][j].w;
			if(vis[v]==false)
			{
				if(d[u]+w<d[v])
				{
					d[v]=d[u]+w;
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if(d[u]+w==d[v])
				{
					pre[v].push_back(u);
				}
			}
		}
	}
}
vector<int> path,temp;
int opt1=INF,opt2=INF;
void DFS(int s)
{
	if(s==0)
	{
		temp.push_back(s);
		int send=0,remain=0;
		for(int i=temp.size()-2;i>=0;--i)
		{
			int need=abs(Cmax/2-C[temp[i]]);
			if(C[temp[i]]<Cmax/2)
			{
				if(remain>need)
					remain-=need;
				else
				{
					send+=need-remain;
					remain=0;
				}
			}
			else
			{
				remain+=need;
			}
		}
		if(send<opt1)
		{
			opt1=send;
			opt2=remain;
			path=temp;
		}
		else if(send==opt1&&remain<opt2)
		{
			opt2=remain;
			path=temp;
		}
		temp.pop_back();
		return ;
	}
	temp.push_back(s);
	for(int i=0;i<pre[s].size();++i)
	{
		DFS(pre[s][i]);
	}
	temp.pop_back();
}
int main()
{
	int s,e,c;
	scanf("%d %d %d %d",&Cmax,&n,&Spr,&m);
	for(int i=1;i<=n;++i)
		scanf("%d",&C[i]);
	for(int i=0;i<m;++i)
	{
		scanf("%d %d %d",&s,&e,&c);
		adj[s].push_back(node(e,c));
		adj[e].push_back(node(s,c));
	}
	Dijkstra(0);
	DFS(Spr);
	printf("%d ",opt1);
	for(int i=path.size()-1;i>=0;--i)
	{
		printf("%d",path[i]);
		if(i!=0)
			printf("->");
	}
	printf(" %d\n",opt2);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/86561056