kuangbin专题十六 KMP&&扩展KMP HDU3613 Best Reward(前缀和+manacher or ekmp)

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value.


InputThe first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000.

OutputOutput a single Integer: the maximum value General Li can get from the necklace.Sample Input
2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac
Sample Output
1
6


必须包含两边,否则价值为0。

manacher:
思路:价值可以前缀和处理一下。然后manacher,枚举分割点,取价值最大

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=500010;
int p[maxn<<1],T,sum[maxn],v[26],pre[maxn],suf[maxn];
char s[maxn],snew[maxn<<1];

int manacher(char* s) {
    memset(pre,0,sizeof(pre));
    memset(suf,0,sizeof(suf));
    int l=0,len=strlen(s);
    snew[l++]='$';
    snew[l++]='#';
    for(int i=0;s[i];i++) {
        snew[l++]=s[i];
        snew[l++]='#';
    }
    snew[l]=0;
    int id=0,mx=0;
    for(int i=0;i<l;i++) {
        p[i]=mx>i?min(p[2*id-i],mx-i):1;
        while(snew[i-p[i]]==snew[i+p[i]]) p[i]++;
        if(i+p[i]>mx) {
            mx=i+p[i];
            id=i;
        }
        if(i-p[i]==0) {
            pre[p[i]-2]=1;//前缀
        }
        if(i+p[i]==l)
            suf[len-(p[i]-1)]=1;//后缀
    }
    int maxx=-1,tmp;
    for(int i=0;i<len-1;i++) {//枚举分割点
        tmp=0;
        if(pre[i]) {
            tmp+=sum[i];
        }
        if(suf[i+1]) {
            tmp+=sum[len-1]-sum[i];
        }
        maxx=max(tmp,maxx);
    }
    return maxx;
}

int main() {
    for(scanf("%d",&T);T;T--) {
        for(int i=0;i<26;i++) scanf("%d",&v[i]);
        scanf("%s",s);
        sum[0]=v[s[0]-'a'];
        for(int i=1;s[i];i++) {
            sum[i]=sum[i-1]+v[s[i]-'a'];
        }
        printf("%d\n",manacher(s));
    }
    return 0;
}

ekmp

将字符串S逆序,然后用S匹配T,T匹配S 如果i+extend[i]==len 说明 i~en-1 是回文串

猜你喜欢

转载自www.cnblogs.com/ACMerszl/p/10329517.html