PAT 甲级 A1055

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_27901091/article/details/79203988
  1. The World’s Richest (25)

时间限制
400 ms
内存限制
128000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line “Case #X:” where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output “None”.
Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct Person{
    char name[15];
    int age;
    int money;

}per[100010];

struct Find{
    int num;
    int low;
    int high;
}fin[1001];

bool cmp(Person a, Person b){
    if (a.money != b.money) return a.money > b.money;
    else if (a.age != b.age) return a.age < b.age;
    else  return strcmp(a.name, b.name)<0;
}


int main(){
    int n, k;
    scanf("%d%d", &n,&k);
    for (int i = 0; i < n; i++){
        scanf("%s%d%d", per[i].name, &per[i].age, &per[i].money);
    }
    sort(per, per + n, cmp);
    for (int i = 1; i <= k; i++){
        scanf("%d%d%d", &fin[i].num, &fin[i].low, &fin[i].high);
    }
    int count;
    for (int i = 1; i <= k; i++){
        int num, low, high;
        num = fin[i].num;
        low = fin[i].low;
        high = fin[i].high;
        printf("Case #%d:\n", i);
        count = 0;

        for (int j = 0; j < n; j++){
            if (per[j].age >= low&&per[j].age <= high) {
                printf("%s %d %d\n", per[j].name, per[j].age, per[j].money);
                count++;
            }
            if (count == num)
            break;  
        }

        if (count == 0) printf("None\n");
    } 

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_27901091/article/details/79203988