PAT A1055

  • 题目:
    Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.
    Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.
Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.
Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

  • 解题思路
    自己思路:
    首先对年龄排序,再对输入的年龄区间按照要求排序。然后再输出这个区间前M个值。
    代码实现:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Max = 100010;
struct People{
    char name[10];
    int age;
    int worth;
} peo[Max];
bool cmp1(People a, People b){
    return a.age < b.age;
}
bool cmp2(People a, People b){
    if(a.worth != b.worth)
        return a.worth > b.worth;                 // 按照财富从大到小排序
    else if(a.age != b.age)
        return a.age < b.age;
    return strcmp(a.name, b.name) < 0;
}
int main()
{
    int N, K;
    cin >> N >> K;
    for(int i =0; i < N; i++){
        scanf("%s%d%d", peo[i].name, &peo[i].age, &peo[i].worth);
    }
    for(int k= 1; k <= K; k++){
        int Max_num, min_age, max_age, count1 = 0, j = Max;
        cin >> Max_num >> min_age >> max_age;
        sort(peo, peo+N, cmp1);                  //按照年龄排序
        for(int i = 0; i < N; i++){
            if(peo[i].age >= min_age && peo[i].age <=max_age){
                count1++;
                if(j > i)                   //获得最开始位置的值
                    j = i;
            }
        }
        sort(peo+j, peo+j+count1, cmp2);        //在这个年龄区间按照规则排序
        if(count1 == 0){
            printf("Case #%d:\n", k);
            printf("None\n");
        }
        else{
            printf("Case #%d:\n", k);
            for(int a = j; a < j+ min(Max_num,count1); a++)
                printf("%s %d %d\n",peo[a].name, peo[a].age, peo[a].worth);
        }
    }
    return 0;
}

这样做测试点2,3会发生超时。这里排序了两次,思考有没有可能只用排序一次。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Max = 100010;
struct People{
    char name[10];
    int age;
    int worth;
} peo[Max];
bool cmp(People a, People b){
    if(a.worth != b.worth)
        return a.worth > b.worth;                 // 按照财富从大到小排序
    else if(a.age != b.age)
        return a.age < b.age;
    return strcmp(a.name, b.name) < 0;
}
int main()
{
    int N, K;
    cin >> N >> K;
    for(int i =0; i < N; i++){
        scanf("%s%d%d", peo[i].name, &peo[i].age, &peo[i].worth);
    }
    sort(peo, peo+N, cmp);             //排序一次
    for(int k= 1; k <= K; k++){
        int Max_num, min_age, max_age, count1 = 0,j = Max;
        bool tag = false;
        cin >> Max_num >> min_age >> max_age;
         printf("Case #%d:\n",k);
        for(int i = 0; i < N; i++){
          if(peo[i].age >= min_age && peo[i].age <=max_age &&count1 < Max_num ){
                printf("%s %d %d\n",peo[i].name, peo[i].age, peo[i].worth);
                tag = true;
                count1++;
            }
        }
        if(!tag)
            printf("None\n");

    }
    return 0;
}

这次只有第二处测试点运行超时。发现只要把最后一处if判断语句里面Max_num > 0放到for循环里面即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Max = 100010;
struct People{
    char name[9];
    int age;
    int worth;
} peo[Max];
bool cmp(People a, People b){
    if(a.worth != b.worth)
        return a.worth > b.worth;                 // 按照财富从大到小排序
    else if(a.age != b.age)
        return a.age < b.age;
    return strcmp(a.name, b.name) < 0;
}
int main()
{
    int N, K;
    scanf("%d%d",&N,&K);
    for(int i =0; i < N; i++){
        scanf("%s%d%d", peo[i].name, &peo[i].age, &peo[i].worth);
    }
    sort(peo, peo+N, cmp);
    for(int k= 1; k <= K; k++){
        int Max_num, min_age, max_age;
        bool tag = false;
        scanf("%d%d%d",&Max_num, &min_age, &max_age);
         printf("Case #%d:\n",k);
        for(int i = 0; i < N &Max_num > 0; i++){
            if(peo[i].age >= min_age && peo[i].age <=max_age ){
                printf("%s %d %d\n",peo[i].name, peo[i].age, peo[i].worth);
                tag = true;
               Max_num--;
            }
        }
        if(!tag)
            printf("None\n");

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao1guaishou/article/details/88818352