UVA10791 Minimum Sum LCM【唯一分解定理】

LCM (Least Common Multiple) of a set of integers is defined as the minimum number, which is a multiple of all integers of that set. It is interesting to note that any positive integer can be expressed as the LCM of a set of positive integers. For example 12 can be expressed as the LCM of 1, 12 or 12, 12 or 3, 4 or 4, 6 or 1, 2, 3, 4 etc.
    In this problem, you will be given a positive integer N. You have to find out a set of at least two positive integers whose LCM is N. As infinite such sequences are
possible, you have to pick the sequence whose summation of elements is minimum. We will be quite happy if you just print the summation of the elements of this set. So, for N = 12, you should print 4+3 = 7 as LCM of 4 and 3 is 12 and 7 is the minimum possible summation.
在这里插入图片描述
Input
The input file contains at most 100 test cases. Each test case consists of a positive integer N (1 ≤ N ≤ 2^31 − 1).
    Input is terminated by a case where N = 0. This case should not be processed. There can be at most 100 test cases.
Output
Output of each test case should consist of a line starting with ‘Case #: ’ where # is the test case number. It should be followed by the summation as specified in the problem statement. Look at the output for sample input for details.
Sample Input
12
10
5
0
Sample Output
Case 1: 7
Case 2: 7
Case 3: 6

问题链接UVA10791 Minimum Sum LCM
问题简述:(略)
问题分析
    给定整数n(1<=n<2^32),求至少两个正整数,使他们的最小公倍数为n,且这些整数的和最小,输出最小的和。
    根据唯一分解定理来实现。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++程序如下:

/* UVA10791 Minimum Sum LCM */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int caseno = 0;
    int n, cnt;
    long long sum;

    while(~scanf("%d", &n) && n) {
        printf("Case %d: ",  ++caseno);

        sum = 0;
        cnt = 0;
        int end = sqrt(n + 1);
        for(int i = 2; i <= end; i++) {
            if(n % i == 0) {
                long long tmp = 1;
                cnt ++;
                while(n % i == 0) {
                    tmp *= i;
                    n /= i;
                }
                sum += tmp;
            }
        }
        if(n != 1 || cnt == 0)
            cnt++, sum += n;
        if(cnt == 1)    sum++;

        printf("%lld\n", sum);
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10463641.html