Accepted Necklace HOJ2660

Accepted Necklace
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4686    Accepted Submission(s): 1861


Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
 

Input
The first line of input is the number of cases. 
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace. 
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight. 
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000. 
 

Output
For each case, output the highest possible value of the necklace.
 

Sample Input
1 
2 1 
1 1 
1 1 
3 
 

Sample Output
1 

搜索+回溯

#include<cstdio>
using namespace std;
struct neck {
	int value;
	int weight;
} necks[21];
int vis[21];
int N,K,W,test;
int weight,value;
int maxValue;
void init() {
	for(int i=0; i<21; i++) vis[i]=0;
	maxValue=0;
}
void dfs(int weight,int value,int start,int k) {
	if(k==K) { //递归结束条件
		if(maxValue < value) maxValue=value;
		return;
	}
	for(int i=start; i<N; i++) {
		if(!vis[i]) {
			if(weight+necks[i].weight<=W) {
				vis[i]=1;
				dfs(weight+necks[i].weight,value+necks[i].value,i+1,k+1);
				vis[i]=0;
			}
		}
	}
}
int main() {
	//freopen("in.txt","r",stdin);
	scanf("%d",&test);
	while(test--) {
		scanf("%d %d",&N,&K);
		for(int i=0; i<N; i++) {
			scanf("%d %d",&necks[i].value,&necks[i].weight);
		}
		scanf("%d",&W);
		init();
		dfs(0,0,0,0);
		printf("%d\n",maxValue);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/jiuweideqixu/article/details/88345209
今日推荐