HDU 2660 Accepted Necklace

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/h84121599/article/details/50815016

Description

I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

INPUT

The first line of input is the number of cases. 
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace. 
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight. 
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000. 

OUTPUT

For each case, output the highest possible value of the necklace.

SAMPLE INPUT

 1 
 2 1 
 1 1 
 1 1 
 3

SAMPLE OUTPUT

 1 

   题目意思是有N个宝石,分别有各自的价值和重量。从中选择K个宝石使选择的宝石加起来价值最大,并且选择的宝石重量不超过W。
	DFS题目,感觉没大难,一步步走就好了


#include<stdio.h>  
#include<string.h>  
#include<iostream>  
using namespace std;
struct stone{
	int w;//重量	
	int p;//价格
}p[21];
int vis[21];
int n, k,wei;
int ans;//记录最高价值
void DFS(int jz,int num,int weight,int j)//jz是总价值,num是已选石头数量,weight是总重量,j是剪枝用,标记当前选到哪个了,避免选到后面的石头后又跑去选择前面的石头,导致重复选择情况
{
	if (num > k ||num==n||weight>wei)return;//剪枝
	if (jz > ans)ans = jz;
	int i;
	for (i = j; i < n; i++){
		if (vis[i] == 1)continue;
		vis[i] = 1;
		DFS(jz+p[i].p,num+1,weight+p[i].w,i+1);
		vis[i] =0;
	}
}
int main()
{
	int N;
	cin >> N;
	while (N--)
	{
		memset(vis, 0, sizeof(vis));
		ans = 0;
		cin >> n >> k;
		int i;
		for (i = 0; i < n; i++){
			cin >> p[i].p >> p[i].w;
		}
		cin >> wei;
		DFS(0, 0, 0, 0);
		cout << ans << endl;
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/h84121599/article/details/50815016