1D: Accepted Necklace

题目来源

题目

I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won’t accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

Input
The first line of input is the number of cases.

For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.

Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.

The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.

Output
For each case, output the highest possible value of the necklace.

Sample Input
1
2 1
1 1
1 1
3

Sample Output
1

题意
我有N块宝石,并计划使用其中的K块为我的母亲制作项链,但她不会接受太重的项链。 考虑到每种宝石的价值和重量,请帮助我找出母亲会接受的最有价值的项链。
输入项
输入的第一行是案例数。
对于每种情况,第一行都包含两个整数N(N <= 20),即宝石总数,而整数K(K <= N),即制造项链的确切宝石数。
然后紧接着N行,每行包含两个整数:a(a <= 1000),代表每种宝石的价值; b(b <= 1000),其重量。
每个案例的最后一行包含一个整数W,W是我母亲可接受的最大重量,W <= 1000。
输出量
对于每种情况,都应输出最高的项链价值。
样本输入
1
2 1
1 1
1 1
3
样本输出
1

解法

N值较小,可以枚举所有可能,当做一道dfs题来做, 但是我没剪枝,超时了,所以贴一个dp的做法,可以把它当成一个二维费用的01背包, 一个是宝石的个数,另一个是宝石的重量

代码

#include <iostream>
#include <cstring>
using namespace std;

int dp[1005][25];
int v[25];
int w[25]; 

int maxx(int n, int m){//这里写max函数是因为vj脑抽,用max居然CE了
	return n>m? n: m;
}

int main(){
	int T;
	cin >> T;
	while(T--){
		int n, k, V;
		cin >> n >> k;
		for(int i=0; i<n; ++i){
			cin >> v[i] >> w[i];
		}
		cin >> V;
		for(int i=0; i<n; ++i){
			for(int j=V; j>=w[i]; --j){
				for(int l=1; l<=k; ++l){
					dp[j][l] = maxx(dp[j][l], dp[j-w[i]][l-1] + v[i]);
				}
			}
		}
		cout << dp[V][k] << endl;
		memset(dp, 0, sizeof(dp));
	}
	
	return 0;
}
发布了14 篇原创文章 · 获赞 0 · 访问量 153

猜你喜欢

转载自blog.csdn.net/loaf_/article/details/103960033