[拼题A] 7-3 Pop Sequence

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Kwong_young/article/details/80634654

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO


队列+栈 模拟

AC代码


#include<iostream>
#include<stack> 
#include<queue> 
using namespace std;

int capacity;
int sequence;
int t;
int out[1100];
void clear_q(queue<int>& q) {
    queue<int> empty;
    swap(empty, q);
}
void clear_s(stack<int>& q) {
    stack <int> empty;
    swap(empty, q);
}
int main() {
//	freopen("aa.txt","r",stdin);
	cin >> capacity >> sequence >> t;
	int a;
	stack <int> s;
	queue<int> q_begin;
	queue<int> q_end;
	while(t--){
		clear_s(s);
		clear_q(q_begin);
		clear_q(q_end);
		for(int i = 1;i <= sequence;i++){
			cin >> a;
			q_begin.push(i);
			q_end.push(a);
		}
		int count = 1;
		while(!q_end.empty()){
			if(!count){
				break;
			}
			int n1 = q_end.front();
			int n2;
			int yes = 0; 
			q_end.pop();
			if(s.size()!=0){
				n2 = s.top();
				if(n2 == n1){
					yes = 1;
					s.pop();
				}else{
					int yes2 = 0;
					int yes3 = 0;
					while(!q_begin.empty()){
						if(yes2){
							break;
						}
						int n3 = q_begin.front();
						q_begin.pop();
						if(n3 == n1){
							yes2 = 1;
							yes3 = 1;
							if(s.size() == capacity){
								count = 0;
							}
						}else{
							s.push(n3);
							if(s.size() > capacity){
								count = 0;
								yes2 = 1;
							}
						}
						
					}
					if(!yes3){
							count = 0;
					}
				}
			}else{
				int yes2 = 0;
				int yes3 = 0;
				while(!q_begin.empty()){
						if(yes2){
							break;
						}
						int n3 = q_begin.front();
						q_begin.pop();
						if(n3 == n1){
							yes2 = 1;
							yes3 = 1;
							if(s.size() == capacity){
								count = 0;
							}
						}else{
							s.push(n3);
							if(s.size() > capacity){
								count = 0;
								yes2 = 1;
							}
						}
						
					}
					if(!yes3){
							count = 0;
						}
			}
		
		}
		if(q_end.size()!=0){
			count = 0;
		}
		if(count){
			cout << "YES" << endl;
		}else{
			cout << "NO" << endl;
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Kwong_young/article/details/80634654