PAT.A1051 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#include<iostream>
#include<string>
#include<set>
#include<map>
#include<utility>
#include<stack>
#include<queue>
using namespace std;

int main() {
	int m, n, k;
	scanf("%d%d%d", &m, &n, &k);
	while (k--) {
		stack<int> s;
		int a[1010];
		for (int i = 0; i < n; i++)
			scanf("%d", &a[i]);
		int q = 1;
		bool f = true;
		for (int i = 0; i < n;i++) {
			for (int j = q; j <= a[i]; j++) {
				s.push(j);
				//printf("%d ", s.size());
				//printf("\n");
				q++;
				if (s.size() > m) {
					f = false;
					break;
				}
			}
			if (a[i] == s.top()) {
				s.pop();
				//printf("%d ", s.top());
				//printf("\n");
			}
			else {
				f = false;
			}
			if (!f) break;
		 }
		if (!f) {
			printf("NO\n");
		}
		else
			printf("YES\n");
			 



		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/mokena1/article/details/80994337